VLANs

Helpfulness: 0
Set Details Share
created 5 years ago by Jenowen
46 views
Based on the VLANs Cheatsheet from http://packetlife.net
updated 5 years ago by Jenowen
Subjects:
ccna, ccent, cisco
show moreless
Page to share:
Embed this setcancel
COPY
code changes based on your size selection
Size:
X
Show:
1

Commands to create a VLAN

Sw(config)#vlan 100

Sw(confg-vlan)#name [name]

2

Commands to configure a port as a Trunk Port

Sw(config-if)#switchport mode trunk

Sw(config-if)#switchport trunk encapsulation dot1q**

Sw(config-if)#switchport trunk allowed vlan [vlan number]

Sw(config-if)#switchport trunk native vlan [vlan number]

** Newer devices only use 802.1q. Therefore, the encapsulation command is neither necessary nor accepted on newer devices (like 2960 switches).

3

Commands to configure a port as an Access Port

Sw(config-if)#switchport mode access

Sw(config-if)#switchport nonegotiate

Sw(config-if)#switchport access vlan [vlan number]

Sw(config-if)#switchport voice vlan [vlan number]
This is optional - for including both voice &data over a trunk

4

VTP Modes

Server

Client

Transparent

5

VTP Domain mode

Common to all switches participating in VTP

6

VTP Server mode

Generates and propagates VTP advertisements to clients

Default mode on unconfigured switches

7

VTP Client mode

Receives and forwards advertisements from servers

VLANs cannot be manually configured on switches in client mode

8

VTP Transparent mode

Forwards advertisements, but does not participate in VTP

VLANs must be configured manually

9

VTP Pruning mode

VLANs not having any access ports on an end switch are removed from the trunk to reduce flooded traffic

10

Commands to configure VTP

Sw(config)#vtp mode [server | client | transparent]

Sw(config)#vtp domain [name]

Sw(config)#vtp password [password]

Sw(config)#vtp version [1 | 2]

Sw(config)#vtp pruning

11

VLAN Terms

Trunking

Carrying multiple VLANs over one physical connection

12

VLAN Terms

Native VLAN

By default, frames in this FLAN are untagged when sent across a trunk

13

VLAN Terms

Access VLAN

The VLAN to which an access port is assigned

14

VLAN Terms

Voice VLAN

If configured, enables minimal trunking to support voice traffic in addition to data traffic on an access port

15

DTP

Dynamic Trunking Protocol

Can be used to automatically establish trunks between capable ports (insecure)

16

SVI

Switched Virtual Interface

A virtual interface which provides a routed gateway into and out of a VLAN

17

Switch Port Modes

trunk - forms an unconditional trunk

dynamic desirable - attempts to negotiate a trunk

dynamic auto - forms a trunk only if requested by other end

access - will never form a trunk

18

VLAN Troubleshooting and show commands

show vlan

show interface [status | switchport]

show interface trunk

show vtp status

show vtp password

19

Default VLAN number

1

20

Maximum number of VLANs in 802.1Q

4094

21

Header size of 802.1Q

4 bytes

22

Header size of ISL

26 bytes

23

Which has both a Header and Trailer, ISL or 802.1Q?

ISL has a 4 byte trailer

24

Another name for 802.1Q

dot1q